Motion - Bug Reports
You are here: Foswiki>Motion Web>BugReports (13 Nov 2016, MrDave)Edit Attach

Bug Reports

The page includes historic bug reports. It is not to be used for reporting any new bugs. New issues should be reported via the github home or reported, discussed and validated on the Motion user mailing list.

New Bugs

Not yet assigned to anyone.

Headline Submitted By Age Last Change
compiling error with latest ffmpeg on raspberrypi MarcoBernardi 926 11 Sep 2016 - 14:57
MarcoBernardi
mask image ignored or wrong setup? WolframFischer 949 21 Aug 2016 - 15:09
WolframFischer
Unable to run python script on_motion* etc... Main.turboy 1006 23 Jun 2016 - 14:22
SimoneRiccardi
Unknown config option for Database options WikiGuest 1042 18 May 2016 - 19:06
VictorO
Problem installing motion WikiGuest 1133 17 Feb 2016 - 16:45
NicoBoileau
Libavformat53 error, not found WikiGuest 1139 12 Feb 2016 - 00:35
RovilsonFMartins
Can't compile with V4L2 Allan Bogh 1166 17 Jan 2016 - 10:48
AllanBogh
Skip corrupted jpeg frame MaurizioA 1192 20 Dec 2015 - 16:18
MaurizioA
Recording timelapse video no longer working StefanBruda 2086 22 Nov 2015 - 18:49
MrDave
Still detecting motion even with "output_normal off" HenkVanHeuveln 1238 22 Nov 2015 - 17:38
MrDave
Captured images are broken if their size is more than 1MB KonstantinSokolov 1249 24 Oct 2015 - 20:38
KonstantinSokolov
logrotate crash HarlanDaneker 1250 23 Oct 2015 - 20:01
HarlanDaneker
segfault in pthread_getspecific() on musl based system WikiGuest 1273 30 Sep 2015 - 20:42
DaveFlogeras
Motion does not work with Chrome DavidRadin 1974 19 Aug 2015 - 17:16
MiKn
event_on_start not working StephenCook 1335 30 Jul 2015 - 23:51
StephenCook
Threads dying randomly, just like BugReport2006x04x07x164654 HolgerJakobs 1470 17 Mar 2015 - 18:23
HolgerJakobs
Memory usage of motion is extremly high if Netcam is in use - Raspberry Pi 512MB WikiGuest 1567 10 Dec 2014 - 21:34
ChristopherStein
Fix for mem leak in read_rtsp_image() ChristopheGRENIER 1568 10 Dec 2014 - 10:31
ChristopheGRENIER
height (1080) is not modulo 16 3.2.12: with 1920 x 1080 GeneC 1573 05 Dec 2014 - 23:36
GeneC
Libjpeg Crash during conversion (YUV420 to JPEG) GiovanniLicata 1666 10 Nov 2014 - 15:41
GiovanniLicata
Multiple Vulnerabilities RvH 2211 10 Oct 2014 - 19:19
MrDave
* Error in `motion': free(): invalid size: 0x00007f960000dc60 * QwazwsxQwazwsx 1647 10 Oct 2014 - 19:00
MrDave
I have problem "netcam_output_message: Invalid SOS parameters for sequential JPEG" WikiGuest 1656 12 Sep 2014 - 12:09
AndrianAndrian
Killing motion makes webcam light stuck to on and device becomes unusable DanielSohn 1716 15 Jul 2014 - 03:38
DanielSohn
Higher 'gap' values in motion.conf break the framerate of the first event movie SimonLemarchand 1785 06 May 2014 - 17:20
SimonLemarchand
Several Instances of Memory leaks NicoleBruck 1791 01 May 2014 - 00:32
NicoleBruck
Recorded Video doesn't play JackYellow 1791 01 May 2014 - 00:20
JackYellow44
Compilation fails at video2.c on Raspberry Pi MartinGogo 1796 26 Apr 2014 - 09:25
MartinGogo
Motion with 2 cameras, only one works bomberb17 1812 09 Apr 2014 - 19:43
PanosXatzi
error: ‘VIDEO_PALETTE_YUV420P’ undeclared Main.Drootnar 1861 20 Feb 2014 - 09:29
DrootnarDrootnar
(PATCH) Handling of bad MJPEG/JPEG data JonGuess 2379 17 Feb 2014 - 06:36
KeithWillis
netcam with host and port does'nt works with proxy GVautier 1869 11 Feb 2014 - 15:02
GillesVautier
Ignore bad frames OERNiiB 1884 28 Jan 2014 - 08:50
OERNiiB
CPU load is not effected if motion detection is paused MaartenOll 1995 08 Oct 2013 - 13:45
MaartenOll
setting minimum_motion_frame to 1 stops image output until restart WilliamPhelps 2005 28 Sep 2013 - 18:24
WilliamPhelps
Mpeg4 video format doesn't work for HTML5 video PedroCorteReal 2053 11 Aug 2013 - 16:29
PedroCorteReal
Error with Threads LuanCasagrande 2062 02 Aug 2013 - 22:32
LuanCasagrande
"Motion thread 1 restart" when running as service JohnMiller 2074 21 Jul 2013 - 17:59
JohnMiller
No rollover if target file size is limited KlausMueller 2098 27 Jun 2013 - 20:20
KlausMueller
"compatible palette" error until fswebcam runs before Motion EricRead 2115 10 Jun 2013 - 18:45
EricRead
Autofocus cameras garbage MustaiMustai 2121 05 Jun 2013 - 03:33
MustaiMustai
mjpg-streaming broken with motion 3.2.12 WikiGuest 2150 07 May 2013 - 11:03
TomHinkle
Motion can't start X Display Applications ("on_event_start") in Daemon mode Main.Yusuf 2187 31 Mar 2013 - 06:51
YusufGungor
Unable to find a compatible palette format. PawelGrzes 2197 20 Mar 2013 - 14:38
PawelGrzes
vloopback_motion.c compile fails NormDePlume 2441 12 Mar 2013 - 16:12
RkaneKnight
8bit Greyscale support missing for uvcvideo device CavaC 2230 15 Feb 2013 - 19:57
CavaC
Errors at make (git version) IboS 2241 05 Feb 2013 - 02:47
IboS
Motion dies after going into daemon mode DazzConway 2259 29 Jan 2013 - 22:09
DazzConway
With two web cams conencted the pictures are mixed together in recordings IainMcFarlane 2832 25 Jan 2013 - 01:43
DazzConway
FLV generated movie files play too fast WikiGuest 2281 27 Dec 2012 - 05:16
OlegRakh
Dual webcam problem on Raspberry Pi WikiGuest 2295 12 Dec 2012 - 16:45
EnricoS
Segmentation fault with iViewHD net camera RzTen1 2316 21 Nov 2012 - 23:05
RzTen1
movie_filename unknown if no ffmpeg YoupMol 2333 05 Nov 2012 - 06:55
YoupMol
Filenames vs displaytime YoupMol 2335 03 Nov 2012 - 09:08
YoupMol
Make fails on file vloopback_motion.c SteveGee 2340 28 Oct 2012 - 21:04
SteveGee
recording fps rate : notice and fix (motion-3.2.12-trunk.r557) BernieK 2348 20 Oct 2012 - 17:17
BernieK
internet conflict with motion. WikiGuest 2352 16 Oct 2012 - 21:07
EdwinKribbs
Cannot compile any version. AndAnd 2390 08 Sep 2012 - 21:04
AndAnd
aera_detect not working at all BeBlochl 2447 19 Aug 2012 - 19:57
BeBlochl
Recent update of ports on FreeBSD = no more working motion WikiGuest 2434 27 Jul 2012 - 02:43
TisugolTisugol
Two USB cams on reporting to same Motion WikiGuest 2951 04 Mar 2012 - 19:29
GillesLatulipe
zero-copy mode of vloopback module on Linux kernel >2.6.32 RaulFajardo 2886 02 May 2011 - 09:09
RaulFajardo
Motion stops recording (but keeps running) WikiGuest 2980 28 Jan 2011 - 08:05
KetilMalde
Motion will crash when attempting to add a thread via the HTTP API. WikiGuest 3011 27 Dec 2010 - 18:26
KyleHotchkiss
motion ignores framerate and minimum_frame_time settings in Debian WikiGuest 3056 13 Nov 2010 - 05:10
JuanAnguloMoreno
Problem with "grey" video from motion AndreyChayka 3099 01 Oct 2010 - 11:08
AndreyChayka
/dev/cxm0 DarrenJohnston 3185 06 Jul 2010 - 23:55
DarrenJohnston
Auto brightness oscillates wildly RobertHancock 3623 25 Apr 2009 - 02:25
RobertHancock
on_camera_lost not triggered if video_pipe doesn't work for any reason. RomanGaufman 3660 03 Apr 2009 - 14:43
RomanGaufman
Motion failed to close motion-stream listen socket after a month of running RomanGaufman 3647 31 Mar 2009 - 15:16
RomanGaufman
Number of topics: 70

Assigned Bugs

Assigned to someone - feel free to help resolving it anyway.

Headline Submitted By Age Last Change Assigned To
Quantization table 0x00 was not defined AlexeyRod 2833 05 Sep 2012 - 23:21
LuisFernandoMita
AngelCarpintero
Video loopback broken with kernels 2.6.38 and above WikiGuest 2813 29 Oct 2011 - 02:36
AngelCarpintero
AngelCarpintero
netcam_next called with non data in buffer NicolaM 3673 04 Jan 2010 - 03:17
AngelCarpintero
AngelCarpintero
on_area_detected, events, gap WikiGuest 3650 09 Jul 2009 - 08:38
AngelCarpintero
JoergWeber
Number of topics: 4

Resolved Bugs

Bugs with a fix. The fix is not yet in a released version of Motion. See also MotionPatches which contains patches for both new features, enhancements and bug fixes.

Headline Submitted By Age Last Change Assigned To
Wireless IP Camera's Not Working MikeHoward 1696 26 Oct 2014 - 22:46
MikeHoward
 
trunkREV557: motion does not insert data to a postgresql db. KarolisE 2295 13 Dec 2012 - 12:41
KarolisE
 
Gentoo emerge motion fails, video2.c undeclared JoeKane 2456 07 Jul 2012 - 18:31
AngelCarpintero
 
motion.c:585:26: error: ‘VIDEO_PALETTE_YUV420P’ undeclared (first use in this function) IgorKuznetsov 2478 14 Jun 2012 - 15:20
AngelCarpintero
AngelCarpintero
Connexion to non-streaming netcam lost after some time F00tyNyupi 3167 28 Jul 2010 - 19:27
F00tyNyupi
 
Unclear explanantion in configuration file for stream_quality RichardB 3342 21 Mar 2010 - 18:35
AngelCarpintero
AngelCarpintero
V4L2 fourcc GRBG not supported IsaacRichter 3435 24 Nov 2009 - 12:20
AngelCarpintero
AngelCarpintero
New spec and init script for Fedora/RedHat systems StevenM 3650 06 Jul 2009 - 13:29
StevenM
 
Number of topics: 8

Monitored Bug Reports

Headline Submitted By Age Last Change
IP cam connection lost and never reconnect LaurentBalthasar 4481 30 Jun 2016 - 00:12
PhilipWalden
Colors not coming out correctly when using webcam with JPEG palette WikiGuest 2775 05 Sep 2012 - 03:54
GatorY
svn/git version don't compile with mysql support under ubuntu 12.04 DannyDeKeuleneire 2449 18 Jul 2012 - 09:00
DannyDeKeuleneire
support for new major ffmpeg release EmmettBrown 2478 18 Jul 2012 - 06:30
AngelCarpintero
Segfault on 16:9 resolution MichaelKirkland 2568 02 Jun 2012 - 04:40
AngelCarpintero
cppcheck FolkertvanHeusden 2490 02 Jun 2012 - 01:56
AngelCarpintero
motion will not compile with ffmpeg EdwinKribbs 3040 29 Oct 2011 - 01:56
AngelCarpintero
motion.c:585:26: error: 'VIDEO_PALETTE_YUV420P' undeclared (first use in this function) WikiGuest 2739 22 Oct 2011 - 17:06
AngelCarpintero
Crash when write mpeg4, swf and etc WikiGuest 2730 22 Oct 2011 - 17:04
AngelCarpintero
Motion will not build with newer kernel headers IgorNovgorodov 2912 10 May 2011 - 06:21
AngelCarpintero
image scrambled, videosyncs inside active picture? RubenD 2950 27 Feb 2011 - 18:56
RubenD
Segmentation fault WikiGuest 3280 10 Feb 2011 - 02:05
AngelCarpintero
Events leave zombies on OpenBSD MotionMark 3255 02 May 2010 - 15:45
AngelCarpintero
Locked pixels FlorinAnton 3544 11 Feb 2010 - 19:06
FlorinAnton
Mac OS X ffmpeg patch/configure error & Motion pthread support error NicholasSund 3748 05 Feb 2010 - 21:14
AngelCarpintero
./configure without ffmpeg WikiGuest 3367 07 Jan 2010 - 10:56
AngelCarpintero
False recordings of gabage TheOtherBug 3533 24 Jul 2009 - 10:50
TheOtherBug
segfault in libc-2.6.1.so WikiGuest 3542 18 Jul 2009 - 00:41
AngelCarpintero
Segmentation fault JeanBono 3568 16 Jul 2009 - 18:57
AngelCarpintero
Motion control 'quit" action does not work. BruceDurham 3794 06 Nov 2008 - 03:05
AngelCarpintero
3.2.9 and Logitech QuickCam Pro 4000: captures 320x240 despite a setting of 640x480 although set to TWikiGuest 3846 15 Sep 2008 - 18:56
DagErlandsson
Logitech Quickcam Messenger : image much too bright TWikiGuest 3908 15 Jul 2008 - 17:31
AngelCarpintero
Need to set norm to NTSC in xawtv for threads beyond 0 WillBuddenberg 4137 15 Jun 2008 - 23:54
AngelCarpintero
Crash on reconect webcam TrebolA 3954 02 Jun 2008 - 16:04
AngelCarpintero
Motion hangs if webcam is removed PekkaVuorela 3965 22 May 2008 - 20:48
PekkaVuorela
post_capture seems to stop on max_mpeg_time :( TWikiGuest 4000 22 May 2008 - 01:13
AngelCarpintero
Stop answering. DanielHolm 4054 20 Feb 2008 - 19:27
DanielHolm
Motion for MACOSX 10.4 (ppc) TWikiGuest 4073 31 Jan 2008 - 09:45
AngelCarpintero
motion 3.2.8 on fox board Luca 4236 08 Jan 2008 - 16:24
AngelCarpintero
multiple definition of `file_protocol' GerbenRoest 4136 02 Dec 2007 - 20:54
AngelCarpintero
compile error with ffmpeg + solution NickKnatterton 4227 31 Aug 2007 - 21:23
AngelCarpintero
motion dies in webcam.c:webcam_add_write:233 Uwe Klein 4440 31 Jan 2007 - 16:19
UweKlein
motion in free(): error: modified (chunk-) pointer. Occurs when I use features ffmpeg on FreeBSD. RafisKhayrullin 4481 08 Jan 2007 - 20:39
AngelCarpintero
Problem with webcam, based on the sn9c102 chip GennadySolovyenko 4528 05 Nov 2006 - 11:52
AngelCarpintero
Links between Camorama and Motion ? AndrewKraknovic 4593 06 Sep 2006 - 00:28
AngelCarpintero
Image is always black TWikiGuest 4648 17 Jul 2006 - 15:19
KonradRiedel
Webcam interface crashes after 24-48 hours. TWikiGuest 4872 22 May 2006 - 18:31
PeterS
Session timeout on netcam MarcBalcells 4698 16 May 2006 - 21:54
AngelCarpintero
disk full TWikiGuest 4779 28 Feb 2006 - 23:29
AngelCarpintero
webcam_localhost behaviour DickMiddleton 4774 28 Feb 2006 - 23:08
AngelCarpintero
segfault after start with WCS2003(same as wvc54g from Linksys) netcam and motion-3.2.2 Mirko Taschenberger 4971 16 Aug 2005 - 22:04
KennethLavrsen
on round robin * glibc detected * free(): invalid pointer: 0xb4658008 * RobertoSpadim 5070 19 Jul 2005 - 03:13
KennethLavrsen
Number of topics: 42

Old Bugs

See ReleaseBugFixes for bugs that have been fixed and the fix is in a released version of Motion.

See RejectedBugReports for bugs that either cannot be reproduced, waiting for additional info or we believe it has been fixed in a new version.

See DuplicatedBugReports for bugs that are duplicates of others
Topic attachments
I Attachment Action Size Date Who Comment
crash_fixes.patchpatch crash_fixes.patch manage 31 K 23 Aug 2015 - 00:11 UnknownUser git change log set of crash fixes
Topic revision: r27 - 13 Nov 2016, MrDave
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.